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OpenOffice.org Overview

All the programs in the OpenOffice.org suite rely on a common interface, and there-

fore look and operate in a similar way. They are also configured in an identical way, and 

all rely on central concepts such as wizards, which guide you through the creation of 

particular types of documents. In addition, many components within the suite are 

shared across the various programs. For example, the automatic chart creation tool 

within Calc can also be used within Writer.

In this chapter, we’ll look at the OpenOffice.org suite as a whole, and explain how it’s 

used and configured. In the following chapters, we’ll examine some specific programs in 

the suite.

Introducing the Interface
If you’ve ever used an office suite, such as Microsoft Office, you shouldn’t find it too hard 

to get around in OpenOffice.org. As with Microsoft Office, OpenOffice.org relies primarily 

on toolbars, a main menu, and separate context-sensitive menus that appear when you 

right-click. In addition, OpenOffice.org provides floating palettes that offer quick access 

to useful functions, such as paragraph styles within Writer. 

Figure 22-1 provides a quick guide to the OpenOffice.org interface, showing the 

following components:

• Menu bar: The menus provide access to most of the OpenOffice.org functions.

• Standard toolbar: This toolbar provides quick access to global operations, such as 

saving, opening, and printing files, as well as key functions within the program being 

used. The Standard toolbar appears in all OpenOffice.org programs and also provides 

a way to activate the various floating palettes, such as the Navigator, which lets you 

easily move around various elements within the document.
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• Formatting toolbar: As its name suggests, this toolbar offers quick access to text-

formatting functions, similar to the type of toolbar used in Microsoft Office applica-

tions. Clicking the B icon will boldface any selected text, for example. This toolbar 

appears in Calc, Writer, and Impress.

• Ruler: The ruler lets you set tabs and alter margins and indents (within programs 

that use rulers).

• Status bar: The status bar shows various aspects of the configuration, such as 

whether Insert or Overtype mode is in use.

• Document area: This is the main editing area.

Most of the programs rely on the Standard and Formatting toolbars to provide access 

to their functions, and some programs have additional toolbars. For example, applications 

such as Impress (a presentation program) and Draw (for drawing vector graphics) have 

the Drawing toolbar, which provides quick access to tools for drawing shapes, adding lines, 

and creating fills (the blocks of color within shapes).

Figure 22-1. The OpenOffice.org interface has several components.
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Customizing the Interface
You can select which toolbars are visible on your screen, as well as customize those that 

are already there. You can also add new toolbars and customize the OpenOffice.org menus.

Adding Functions to Toolbars

The quickest way to add icons and functions to any toolbar is to click the two small arrows 

at the right of a toolbar and select the Visible Buttons entry on the menu that appears. This 

will present a list of currently visible icons and functions, along with those that might 

prove useful on that toolbar but are currently hidden. Any option already visible will have 

a check next to it.

Additionally, you can add practically any function to a toolbar, including the options from 

the main menus and many more than those that are ordinarily visible. Here are the steps:

1. Click the two small arrows to the right of a toolbar, and select the Customize 

Toolbar option.

2. In the Customize dialog box, click the Add button in the Toolbar Content section to 

open the Add Commands dialog box, as shown in Figure 22-2. 

Figure 22-2. Adding a new function to the toolbar is very easy within OpenOffice.org.
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3. Choose a category from the list on the left to see the available commands in the list 

on the right. The categories of functions are extremely comprehensive. For example, 

under the Format category, you’ll find entries related to specific functions, such as 

increasing font sizes or setting a shadow effect behind text. Table 22-1 provides 

brief descriptions of each of the categories listed in the Add Commands dialog box.

4. Select the function you want to add on the right side of the Add Commands dialog 

box, and then click the Add button. 

5. Click the Close button. You’ll then see your new function in the list of icons in the 

Customize dialog box, under the Toolbar Content heading. The new icon will be 

automatically selected.

6. Click and drag to move the new function left or right on the toolbar itself (you’ll see 

the toolbar itself update when you release the mouse button). Alternatively, you 

can highlight the icon and click the up and down arrows next to the list. To temporarily 

hide the new icon, or any other icon, remove the check from alongside it.

Table 22-1. OpenOffice.org Toolbar Customization Categories

Category Description

Application These options relate to the specific OpenOffice.org application you’re using. 
For example, if you select to customize a toolbar within Writer, the Application 
category menu will offer functions to start AutoPilots (effectively wizards) 
that will build word processor documents.

View This category offers options related to the look and feel of the suite, such as 
which items are visible within the program interface.

Templates In this category, you’ll find options related to the creation and use of 
document templates.

Edit This category contains options related to cutting, pasting, and copying items 
within the document, as well as updating elements within it.

Options These are various options that relate to configuration choices in 
OpenOffice.org, allowing you to control how it works.

BASIC Options under this category relate to the creation and playback of 
OpenOffice.org macros.

Insert This category includes options related to inserting objects, such as sound, 
graphics, and elements from other OpenOffice.org documents.

Documents This category provides options specific to document control, such as those 
related to exporting documents as PDF files or simply saving files.

Format Here, you’ll find a range of options related largely to text formatting, but also 
some concerned with formatting other elements, such as drawings and images.
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Many functions that can be added are automatically given a relevant toolbar icon, but 

you can choose another icon for a function by selecting the icon in the list in the Customize 

dialog box, clicking Modify, and then selecting Change Icon. You can also use this method 

to change an icon that already appears on a toolbar. 

■Note  To delete an icon from a toolbar, click the two small arrows to the right of a toolbar, and select the 

Customize Toolbar option. Select the icon you want to remove, click the Modify button, and choose to delete it. 

Adding a New Toolbar

If you want to add your own new toolbar to offer particular functions, you’ll find it easy to 

do. Here are the steps:

Controls Under this heading, you’ll find widgets that can be used in conjunction with 
formulas or macros, such as check boxes, buttons, text box creation tools, 
and so on.

Navigate This category offers tools that let you move around a document quickly, such 
as the ability to quickly edit headers and footers, or move from the top of the 
page to the end very quickly.

Table Here, you’ll find options related to the creation of tables.

Drawing Here, you’ll find tools related to drawing objects, such as shapes and lines, 
and also tools for creating floating text boxes.

Graphic This category presents a handful of options related to manipulating bitmap 
graphics that are inserted into the document.

Data Here, you’ll find a couple of options related to working with information 
sources, such as databases.

Frame These options relate to any frames inserted into the document, such as 
how elements within the frame are aligned and how text is wrapped around 
the frame.

Numbering These are various options related to creating automatic numbered or 
bulleted lists.

Modify These options relate to the drawing components within OpenOffice.org and 
let you manipulate images or drawings in various ways by applying filters.

OpenOffice.org 
BASIC Macros

Here, you can select from various ready-made macros, which provide some of 
OpenOffice.org’s functions.

Table 22-1. OpenOffice.org Toolbar Customization Categories (Continued)

Category Description
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1. Click the two small arrows to the right of any toolbar and select Customize Toolbar 

from the list of options. Don’t worry—you’re not actually going to customize that 

particular toolbar!

2. In the Customize dialog box, click the New button at the top right. 

3. Give the toolbar a name. The default entry for the Save In field is correct, so you 

don’t need to alter it.

4. Populate the new toolbar, following the instructions in the previous section. 

5. Once you’ve finished, click the OK button. 

You should see your new toolbar beneath the main toolbars. To hide it in the future, 

click View ➤ Toolbars, and then remove the check alongside the name of your toolbar. 

Customizing Menus

You can also customize the OpenOffice.org menus. Here are the steps:

1. Select Tools ➤ Customize from the menu bar. 

2. In the Customize dialog box, select the Menus tab at the top left. 

3. Choose which menu you wish to customize from the Menu drop-down list. 

4. Select the position where you wish the new function to appear on the menu, by 

selecting an entry on the menu function list, and then click the Add button. 

5. Add commands to the menu, as described earlier in the “Adding Functions to 

Toolbars” section.

The up and down arrows in the Customize dialog box allow you to alter the position 

of entries on the menu. You could move those items you use frequently to the top of the 

menu, for example.

You can remove an existing menu item by highlighting it in the Customize dialog box, 

clicking the Modify button, and then clicking Delete.

If you make a mistake, simply click the Reset button at the bottom right of the Customize 

dialog box to return the menus to their default state.
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Configuring OpenOffice.org Options

In addition to the wealth of customization options, OpenOffice.org offers a range of 

configuration options that allow you to make it work exactly how you wish. Within an 

OpenOffice.org program select Tools ➤ Options from the menu to open the Options 

dialog box, as shown in Figure 22-3.

Figure 22-3. OpenOffice.org’s main configuration options are accessed by selecting 

Tools ➤ Options.

Most of the configuration options offered within each program apply across the suite, 

but those under the heading of the program’s name apply only to the program in use. In 

other words, to set the options specific to Calc, you need to use the Calc Options dialog 

box. But to set global options for the entire suite, you can use any program’s Options 

dialog box.
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A variety of options are offered, allowing you to tweak everything from the default file 

format to the colors used by default within the software. Table 22-2 briefly describes each 

of the OpenOffice.org configuration options.

Table 22-2. OpenOffice.org Configuration Options

Option Description

OpenOffice.org

User Data This is the personal data that will be added to the documents you create. 
You can leave this area blank if you wish.

General This offers a handful of miscellaneous options, such as how to handle 
two-digit dates, when the help system should step in to offer tips, how the 
help system should be formatted (such as in high resolution for people 
with vision problems), and whether printing a document is interpreted by 
OpenOffice.org as modifying it.

Memory This entry relates to how much system memory OpenOffice.org can use. 
You can limit the number of undo steps, for example, and alter the cache 
memory used for holding graphical objects.

View Here, you can alter the look, feel, and operation of OpenOffice.org. You can 
define whether the middle mouse button performs a paste operation (which is 
consistent with how Ubuntu works), or whether it should perform a scrolling 
function, as with Windows. You can also alter elements such as whether 
icons appear in menus and if fonts are previewed in the toolbar menu.

Print This option lets you adjust how printing is handled within OpenOffice.org. 
The functions relate to those that can stop documents from printing 
incorrectly, such as reducing any transparency effects within the documents 
so on-page elements don’t appear faint or completely disappear in the 
final output. (Note that specific print functions are handled within the 
Print dialog box when you actually print a document.)

Paths This is where the file paths for user-configured and vital system tools are 
handled. Generally, there’s little reason to edit this list, although you might 
choose to alter the default location where your documents are saved (simply 
double-click the My Documents entry to do this).

Colors Here, you can define the default color palette that appears in the various 
programs in the suite. 

Fonts By creating entries here, you can automatically substitute fonts within doc-
uments you open for others on your system. If you don’t have the Microsoft 
core fonts installed, this might prove useful. For example, you might choose 
to substitute Arial, commonly used in Microsoft Office documents, for 
Luxi Sans, one of the sans serif fonts used under Ubuntu.

Security This option controls which types of functions can be run within 
OpenOffice.org. For example, you can choose whether macros created 
by third parties should be run when you open a new document.

Appearance Here, you can alter the color scheme used within OpenOffice.org, in a simi-
lar way to how you can alter the default Ubuntu desktop color scheme. 
Individual elements within documents and pages can be modified, too.



C HA P TE R  2 2  ■  OP E N OF F I CE . OR G  OV E R V I E W 471

Accessibility This option relates to features that might help people with vision disabilities to 
use OpenOffice.org. For example, you can define whether animated graphics 
are shown on the screen.

Java This option lets you control whether you use the Java Runtime Environ-
ment, which may be necessary to use some of OpenOffice.org’s features.

Load/Save

General Options here relate to how files are saved. You can select whether the default 
is to save in OpenOffice.org or Microsoft Office format. Choosing the latter 
is useful if you share a lot of documents with colleagues who are not running 
OpenOffice.org.

VBA Properties This option relates to how Visual Basic for Applications (VBA) code is handled 
when Microsoft Office documents are opened. Specifically, it ensures that 
the code isn’t lost when the file is saved again.

Microsoft Office This option provides functions specifically needed to convert or open 
Microsoft Office files within OpenOffice.org.

HTML 
Compatibility

Here, you can set options that affect the compatibility of HTML files saved 
within OpenOffice.org.

Language Settings

Languages Here, you can set your local language so that documents are spell-checked 
correctly. In addition, Asian language support can be activated, which 
allows for more complex document layout options.

Writing Aids Under this option, you can activate or deactivate various plug-ins designed 
to help format documents, such as the hyphenator or the spell-checking 
component. In addition, you can alter how the spell-checker works, such as 
whether it ignores capitalized words.

OpenOffice.org Writer

General Here, you can alter various options related to the editing of word processor 
documents, such as which measurements are used on the ruler (centimeter, 
inches, picas, and so on). 

View Under this option, you can configure the look and feel of the Writer program, 
such as which scroll bars are visible by default. You can also turn off the 
display of various page elements, such as tables and graphics.

Formatting Aids This option lets you choose which symbols appear for “invisible” elements 
(such as the carriage return symbol or a dot symbol to indicate where spaces 
have been inserted) in Writer.

Grid This controls whether page elements will snap to an invisible grid. You can 
also define the dimensions and spacing of the grid cells here.

Basic Fonts 
(Western)

This controls which fonts are used by default in the various text styles, such 
as for the default text and within lists.

Print This option offers control over printing options specific to Writer, such as 
which page elements are printed (you might choose to turn off the printing 
of graphics, for example). 

Table 22-2. OpenOffice.org Configuration Options (Continued)

Option Description
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Tables Here, you can control how tables are created and how you interact with 
them within Writer. For example, you can control what happens when a ta-
ble is resized, such as whether the entire table responds to the changes or 
merely the cell you’re resizing.

Changes This option lets you define how changes are displayed when the track 
changes function is activated.

Compatibility Here, you can set specifics of how Writer handles the import and export of 
Microsoft Word documents.

AutoCaption This offers settings for the AutoCaption feature within Writer.

Mail Merge E-Mail This option lets you control the sending of e-mail mail merge messages.

OpenOffice.org Writer/Web

View Here, you can control the HTML editor component of OpenOffice.org 
(effectively an extension of Writer). You can control the look and feel of the 
HTML editor, including which elements are displayed on the screen.

Formatting Aids As with the similar entry for Writer under Text Document, this option lets 
you view symbols in place of usually hidden text elements.

Grid This lets you define a grid that on-screen elements are able to “snap to” in 
order to aid accurate positioning.

Print Here, you can define how HTML documents created within OpenOffice.org 
are printed.

Table Similar to the Tables entry under Text Document, this controls how tables 
are created and handled within HTML documents.

Background This lets you set the default background color for HTML documents.

OpenOffice.org Calc

General Here, you can modify miscellaneous options related to Calc, such as which 
measurement units are used within the program and how the formatting of 
cells is changed when new data is input.

View This option relates to the look and feel of Calc, such as the color of the grid 
lines between cells and which elements are displayed on the screen. For 
example, you can configure whether zero values are displayed, and whether 
overflow text within cells is shown or simply truncated at the cell boundary.

Calculate This option relates to how numbers are handled during certain types of 
formula calculations, such as those involving dates. 

Sort Lists This option lets you create lists that are applied to relevant cells when the 
user chooses to sort them. Several lists are predefined to correctly sort days 
of the week or months of the year.

Changes This option relates to the on-screen formatting for changes when the track 
changes function is activated.

Grid This option lets you configure an invisible grid that stretches across the 
sheet and which page objects can be set to snap to the grid for correct 
alignment.

Table 22-2. OpenOffice.org Configuration Options (Continued)

Option Description
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Print This option relates to printing specifically from Calc, such as whether Calc 
should avoid printing empty pages that might occur within documents.

OpenOffice.org Impress

General This option refers to miscellaneous settings within the Impress program, 
such as whether the program should always start with a wizard and which 
units of measurement should be used.

View This option relates to the look and feel of Impress, and, in particular, whether 
certain on-screen elements are displayed.

Grid This controls whether an invisible grid is applied to the page and whether 
objects should snap to it.

Print This option controls how printing is handled within Impress and, in 
particular, how items in the document will appear on the printed page.

OpenOffice.org Draw

General This option relates to miscellaneous settings within Draw (the vector 
graphics component of OpenOffice.org).

View Here, you can set specific preferences with regard to which objects are 
visible on the screen while you’re editing with Draw.

Grid This option relates to the invisible grid that can be applied to the page.

Print This option lets you define which on-screen elements are printed and which 
are not printed.

OpenOffice.org Base

Connections This option lets you control how any data sources you attach to are handled.

Databases Here, you can configure which databases are registered for use within Base.

Chart

Default Colors Here, you can set the default color palette that should be used when creating 
charts, usually within the Calc program.

Internet

Proxy Here, you can configure network proxy settings specifically for 
OpenOffice.org, if necessary.

Search Certain functions within various OpenOffice.org programs let you search 
the Internet. Here, you can configure how these search functions work.

E-mail This option lets you specify which program you wish OpenOffice.org to use 
for e-mail.

Mozilla Plug-in This function allows integration of OpenOffice.org into the Mozilla and/or 
Netscape browsers, to allow the viewing of OpenOffice.org documents 
within the browser window.

Table 22-2. OpenOffice.org Configuration Options (Continued)

Option Description
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Using OpenOffice.org Core Functions
Although the various programs within OpenOffice.org are designed for very specific tasks, 

they all share several core functions that work in broadly similar ways. In addition, each 

program is able to borrow components from other programs in the suite. 

Using Wizards

One of the core functions you’ll find most useful when you’re creating new documents is 

the wizard system, which you can access from the File menu. A wizard guides you through 

creating a new document by answering questions and following a wizard-based interface. 

This replaces the template-based approach within Microsoft Office, although it’s worth 

noting that OpenOffice.org is still able to use templates.

A wizard will usually offer a variety of document styles. Some wizards will even prompt you 

to fill in salient details, which they will then insert into your document in the relevant areas.

Getting Help 

OpenOffice.org employs a comprehensive help system, complete with automatic context-

sensitive help, called the Help Agent, which will appear if the program detects you’re 

performing a particular task. Usually, the Help Agent takes the form of a light bulb graphic, 

which will appear at the bottom-right corner of the screen. If you ignore the Help Agent, it 

will disappear within a few seconds. Clicking it causes a help window to open. Alternatively, 

you can access the main searchable help file by clicking the relevant menu entry.

Inserting Objects with Object Linking and Embedding

All the OpenOffice.org programs are able to make use of Object Linking and Embedding 

(OLE). This effectively means that one OpenOffice.org document can be inserted into 

another. For example, you might choose to insert a Calc spreadsheet into a Writer document. 

The main benefit of using OLE over simply copying and pasting the data is that the OLE 

item (referred to as an object) will be updated whenever the original document is revised. 

In this way, you can prepare a report featuring a spreadsheet full of figures, for example, 

and not need to worry about updating the report when the figures change. Figure 22-4 

shows an example of a spreadsheet from Calc inserted into a Writer document.

Whenever you click inside the OLE object, the user interface will change so that you 

can access functions specific to that object. For example, if you had inserted an Impress 

object into a Calc document, clicking within the object would cause the Calc interface to 

temporarily turn into that of Impress. Clicking outside the OLE object would restore the 

interface back to Calc.
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You can explore OLE objects by selecting Insert ➤ Object ➤ OLE Object. This option 

lets you create and insert a new OLE object, as well as add one based on an existing file. To 

ensure the inserted OLE object is updated when the file is, check the Link To File box in 

the Insert OLE Object dialog box.

Figure 22-4. Object Linking and Embedding (OLE) lets you incorporate one OpenOffice.org 

document into another.

Creating Macros

OpenOffice.org employs a powerful BASIC-like programming language, which you can 

use to create your own functions. Although this language is called BASIC, it is several 

generations beyond the BASIC you might have used in the past. OpenOffice.org’s BASIC is 

a high-level, object-oriented environment designed to appeal to programmers who wish 

to quickly add their own functions to the suite. 

However, it’s possible for any user to record a series of actions as a macro, which is 

then automatically turned into a simple BASIC program. This can be very useful if you 

wish to automate a simple, repetitive task, such as the insertion of a paragraph of text, or 

even something more complicated, such as searching and replacing text within a document. 

To record a macro, select Tools ➤ Macros ➤ Record Macro. After you’ve selected this 

option, any subsequent actions will be recorded. All keyboard strokes and clicks of the 
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mouse will be captured and turned automatically into BASIC commands. To stop the 

recording, simply click the button on the floating toolbar. After this, you’ll be invited to 

give the macro a name (look to the top left of the dialog box). Once you’ve done so, a 

dialog box will appear, into which you can type a name for the macro (in the Macro Name 

text box). Then, click Save. You can then run your macro in the future by choosing Tools ➤ 

Macros ➤ Run Macro. Simply expand the My Macros and Standard entries at the top left 

of the dialog box, click Module1, select your macro in the list on the right, and click Run.

Saving Files

As mentioned in Chapter 21, OpenOffice.org uses the OpenDocument range of file formats. 

The files end with an .ods, .odt, .odp, or .odb file extension, depending on whether they’ve 

been saved by Calc, Writer, Impress, or Base, respectively. The OpenDocument format is 

the best choice when you’re saving documents that you are likely to further edit within 

OpenOffice.org. However, if you wish to share files with colleagues who aren’t running 

Ubuntu or OpenOffice.org, the solution is to save the files as Microsoft Office files. To save 

in this format, just choose it from the Save As drop-down list in the Save As dialog box. If 

your colleague is running an older version of OpenOffice.org or StarOffice, you can also 

save in those file formats.

Alternatively, you might wish to save the file in one of the other file formats offered in 

the Save As drop-down list. However, saving files in an alternative format might result in 

the loss of some document components or formatting. For example, saving a Writer docu-

ment as a simple text file (.txt) will lead to the loss of all of the formatting, as well as any of 

the original file’s embedded objects, such as pictures.

To avoid losing document components or formatting, you might choose to output your 

OpenOffice.org files as Portable Document Format (PDF) files, which can be read by the 

Adobe Acrobat viewer. The benefit of this approach is that a complete facsimile of your 

document will be made available, with all the necessary fonts and on-screen elements 

included within the PDF file. The drawback is that PDF files cannot be loaded into 

OpenOffice.org for further editing, so you should always save an additional copy of the file 

in the native OpenOffice.org format. To save any file as a PDF throughout the suite, select 

File ➤ Export As PDF. Then choose PDF in the File Type drop-down box, as shown in 

Figure 22-5.
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Figure 22-5. All the programs in the suite can export files in Adobe PDF format.

Summary
In this chapter, we looked at the configuration options provided with OpenOffice.org. You 

were introduced to the user interface, which is shared across all the programs within the 

suite, and learned how it can be customized. We also examined some common tools 

provided across the suite of programs, such as macro generation.

Over the following chapters, we will look at each major component of the suite, starting 

with Writer.


